News:

Current Full E-Touch Version: 10.2.0
Current Demo E-Touch Version: 10.0.0
Current Beta: 10.2.1 Beta 18 (23/10/21)

Main Menu

Jump to Letter Button

Started by Cary_B, September 26, 2021, 04:06:54 PM

Previous topic - Next topic

Cary_B

Barry, finally had time to do some more research on my jump to letter button problem.  If you recall, it seems that the JUMP TO LETTER button works great on the main artist screen.  But on the Filter by Artist screen, every button is off by one letter.  If I hit B, it jumps to C, if I hit G, it jumps to H.  You mentioned that you had recoded it so that the album screen and the filter by screen use the same code. 

After a whole bunch of checking all my tags to make sure it wasn't a tag issue, I think I have finally narrowed it down.  The JUMP TO LETTER screen that pops up on both of the ablum screen and filter by artist screen use the jumptoletter_v2.ini file.  So far so good.  The problem comes in is that the artist screen expects the letters in the .ini file to Start with A, and end with #.  But the filter by artist expects the .ini file to start with # and end with Z.

I edited the .ini file and (which currently looks like this:

\images\Page_jump_to.jpg
800
260
200
1400
5
85
80
80
\images\Letter_A.png
5
170
80
80
\images\Letter_B.png
5
255
80
80
\images\Letter_C.png
5
340
80
80
\images\Letter_D.png
5
425
80
80
\images\Letter_E.png
5
510
80
80
\images\Letter_F.png
5
595
80
80
\images\Letter_G.png
5
680
80
80
\images\Letter_H.png
5
765
80
80
\images\Letter_I.png
5
850
80
80
\images\Letter_J.png
5
935
80
80
\images\Letter_K.png
5
1020
80
80
\images\Letter_L.png
5
1105
80
80
\images\Letter_M.png
5
1190
80
80
\images\Letter_N.png
100
85
80
80
\images\Letter_O.png
100
170
80
80
\images\Letter_P.png
100
255
80
80
\images\Letter_Q.png
100
340
80
80
\images\Letter_R.png
100
425
80
80
\images\Letter_S.png
100
510
80
80
\images\Letter_T.png
100
595
80
80
\images\Letter_U.png
100
680
80
80
\images\Letter_V.png
100
765
80
80
\images\Letter_W.png
100
850
80
80
\images\Letter_X.png
100
935
80
80
\images\Letter_Y.png
100
1020
80
80
\images\Letter_Z.png
100
1105
80
80
\images\Letter_#.png
95
1200
100
100
\images\Close_Button.png

Like this, the main album screen works fine, but the filter by artist screen is off by one.

I changed it to this:

\images\Page_jump_to.jpg
800
260
200
1400
5
85
80
80
\images\Letter_#.png
5
170
80
80
\images\Letter_A.png
5
255
80
80
\images\Letter_B.png
5
340
80
80
\images\Letter_C.png
5
425
80
80
\images\Letter_D.png
5
510
80
80
\images\Letter_E.png
5
595
80
80
\images\Letter_F.png
5
680
80
80
\images\Letter_G.png
5
765
80
80
\images\Letter_H.png
5
850
80
80
\images\Letter_I.png
5
935
80
80
\images\Letter_J.png
5
1020
80
80
\images\Letter_K.png
5
1105
80
80
\images\Letter_L.png
5
1190
80
80
\images\Letter_M.png
100
85
80
80
\images\Letter_N.png
100
170
80
80
\images\Letter_O.png
100
255
80
80
\images\Letter_P.png
100
340
80
80
\images\Letter_Q.png
100
425
80
80
\images\Letter_R.png
100
510
80
80
\images\Letter_S.png
100
595
80
80
\images\Letter_T.png
100
680
80
80
\images\Letter_U.png
100
765
80
80
\images\Letter_V.png
100
850
80
80
\images\Letter_W.png
100
935
80
80
\images\Letter_X.png
100
1020
80
80
\images\Letter_Y.png
100
1105
80
80
\images\Letter_Z.png
95
1200
80
80
\images\Close_Button.png


And now the main album screen is off by one, and the filter by artist screen works fine.

So it seems that while the code to bring up the screen is fine, they are both expecting the letters and the # sign to be in different orders in the .ini file.  If you could look into this, that would be great.  Also, It would be great if you could use the version with the # first for both, as that is how the probram filters and sorts on the screen, but I am sure that would probably break a lot of skins, so whatever is the best solution to fix this is ok..

Thanks for all the hard work you do on the program.



Barcrest

You were correct. This has been fixed and will be in the next release.
Keep on Rocking in the Free World \m/ ;D\m/



Jukebox Stats...