News:

Current Full E-Touch Version: 10.2.0
Current Demo E-Touch Version: 10.0.0
Current Beta: 10.2.1 Beta 18 (23/10/21)

Main Menu

Config build with different libraries

Started by Cary_B, September 30, 2021, 08:06:53 PM

Previous topic - Next topic

Cary_B

Ok Barry, here is a strange one for you:

I Just started experimenting with different library's.  Was looking into start adding videos to my jukebox.  But ran into a few inconsistancies with how the library's are built if you use more that just the main audio library.

Here is what I found:

Build the AUDIO library, use GENERATE and CLEAR for all six checkboxes.  All is good.  The Audio Screen filters fine and all albums show.  Filter by Artist, Year, and Genre all work perfectly.

Now Build the VIDEO library, Use GENERATE and CLEAR for all six checkboxes.  Problems begin.  Both AUDIO and VIDEO filering works as expected.  But Filter by ARTIST only shows the AUDIO files, and no VIDEO Files.  Filter by YEAR and GENRE show only the VIDEO FILES. (As expected I think, since I used clear when building libraries.)

So, back to square one.

Build the AUDIO library, use GENERATE and CLEAR for all six checkboxes.  All is good.  The Audio Screen filters fine and all albums show.  Filter by Artist, Year, and Genre all work perfectly. (Again)

Now Build the VIDEO library, USE GENERATE but this time don't use CLEAR for the three options.  Again, both AUDIO and VIDEO filtering work as expected, again fitler by ARTIST still only shows the AUDIO files, but now filter by YEAR and GENRE show both AUDIO and VIDEO files.  Except, they are alphabetized by AUDIO FILES, then VIDEO FILES.  The two libraries are not mixed together to sort, but just added one after the other into one file it seems.

I went back, added files to all the libraries (AUDIO, VIDEO, KARAOKE, and RADIO) and generated again, this time without using the CLEAR options at all.  Same results.  FILTER by ARTIST still only shows the AUDIO files, and now the filter by GENRE and YEARS show all the files, again alphabatized by library, then ABC order withing the library's.

So it appears that the only way to use the different librarys at this time is to generate your AUDIO library last, and make sure to use CLEAR on all three options.  This way, your audio file will filter by ARTIST, YEAR, and GENRE correclty, but no files from VIDEO, KARAOKE, or RADIO will be in the filters.

I also tried searching for songs after building all four library's (first generating the audio library using clear, then the other three libraries no using clear).  Search for a song in the audio library worked great.  (As expected.)  In fact the search function worked great. Whichever library I was in found the songs in that libary, but not other libary's. And if I searched for a song in another libary (Say a song in the VIDEO libary while I was in the AUDIO libary, it wouldn't find it till I hit the Search button for that particular libary.  So that seems to work perfectly as expected. The only inconsistancy was that it didn't fine any files for radio at all.  I assume that is by design as  the radio button is not for regular mp3 or video files.  So just letting you know that search seems to work perfectly.

Oh, and one last thing. (Sorry about length of this message)  The config program doesn't seem to save your settings correctly all the time.  I load it up, set all my settings, and close the program and all settings are saved.  If I load it up, generate the libaries, then close it, not all settings seem to be saved. So I have to make sure to make all changes, close the program, then reload and then generate so that all the options I want are saved for the next time I want' to use it.

Cary_B

Oh, and just to let you know, I went back and tested everything again, this time using UPDATE library instead of GENERATE and still got the same results, just in case this was all the way it was supposed to work and I was just using the wrong function to build my libraries. 

Barcrest

Ok, I can look at why the settings are not saving.

Are you using the generate in advanced mode when they are not saving or from the simple menu that appears before?

The whole filtering issue is a big job. If you look at the folder structure you will see that they are not stored the same as audio files are for the other libraries. It was part of a overhaul of how it all works that never got completed and may not be.

The radio doesn't really use tags so that is why that works differently from other libraries.
Keep on Rocking in the Free World \m/ ;D\m/



Jukebox Stats...

Cary_B

I always use the advanced mode to test and build my libraries.  (Unless I build them using my startup config file, then they just use the last saved options anyways.)

And its not really a huge deal it you never get to this.  I understand its a huge job.  I'll probably only ever use the MUSIC and VIDEO libraries, and as long as I build my MUSIC library last, I should be ok.  Just letting you know its out there.

Thanks for looking at it.